Delayed Email Notifications & Announcement Processing
Incident Report for Condo Control
Resolved
This incident has been resolved.
Posted Jul 15, 2024 - 20:22 EDT
Investigating
We are currently investigating an issue with delayed processing of announcement email notifications.
Posted Jul 15, 2024 - 16:15 EDT
This incident affected: Outbound Email.