Delayed Email Notifications & Announcement Processing
Incident Report for Condo Control
Resolved
This incident has been resolved.
Posted Jul 16, 2024 - 19:48 EDT
Monitoring
Some users may experience a delay in emails notifications and/or announcements. We will monitor the issue until it is fully resolved.
Posted Jul 16, 2024 - 15:50 EDT
This incident affected: Outbound Email.