Our maintenance has now been completed. We will continue working through the adjustments to continue improving the system performance. We will be opening an incident while the system remains online and posting updates as we progress.
Posted Mar 12, 2025 - 09:22 EDT
Update
One of the performance improvements we planned to introduce today has not worked as expected. We are troubleshooting, and we will begin a rollback if we cannot resolve this issue within the next 15 minutes.
Posted Mar 12, 2025 - 09:04 EDT
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Mar 12, 2025 - 08:22 EDT
Scheduled
We will be undergoing scheduled maintenance during this time.
Posted Mar 12, 2025 - 08:21 EDT
This scheduled maintenance affected: Web Application, Mobile App / API, Online Payment Services, Public Websites, Outbound Email, Text & Voice Messaging, and Accounting Integration.