Business Phone Outage

Incident Report for Condo Control

Resolved

Zoom service has been restored, and our business phone line is operational once more. Thanks for your patience.
Posted Apr 16, 2025 - 16:59 EDT

Identified

Condo Control uses Zoom Phone systems, which is currently experiencing a partial outage. We are monitoring their recovery and will keep you informed as soon as normal service resumes. During this outage, please submit support requests via the help feature. For more detail, see here: https://support.condocontrol.com/hc/en-us/articles/7068007444379-Web-Browser-How-to-Create-a-Help-Ticket
Posted Apr 16, 2025 - 16:39 EDT