System responding slow to actions

Incident Report for Condo Control

Resolved

System has returned to normal operations. Our maintenance release on Thursday contains many fixes related to our recent performance challenges. Thank you for your patience while we work through these upgrades.
Posted Mar 18, 2025 - 16:39 EDT

Investigating

We are currently investigating this issue. We apologize for any inconvenience.
Posted Mar 18, 2025 - 16:15 EDT
This incident affected: Web Application.