Email Processing Delays
Incident Report for Condo Control
Resolved
This incident has been resolved.
Posted May 26, 2023 - 21:46 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 26, 2023 - 17:41 EDT
This incident affected: Outbound Email.