System responding slow to actions

Incident Report for Condo Control

Resolved

This incident has been resolved.
Posted Mar 03, 2025 - 17:18 EST

Investigating

We are currently experiencing slower-than-usual response times when performing actions within the system. Our team is actively investigating the issue, and we will provide updates as soon as more information becomes available.
Posted Mar 03, 2025 - 15:30 EST
This incident affected: Web Application.