System responding slow to actions

Incident Report for Condo Control

Resolved

The platform has resumed normal operations. We have identified several critical system improvements, and we anticipate releasing them early next week.
Posted Mar 07, 2025 - 17:26 EST

Investigating

We are currently investigating this issue.
Posted Mar 07, 2025 - 14:56 EST
This incident affected: Web Application.