System responding slow to actions

Incident Report for Condo Control

Resolved

The platform has resumed normal operations. We have identified several critical system improvements, and we anticipate releasing them Wednesday morning
Posted Mar 10, 2025 - 17:21 EDT

Investigating

We are currently investigating this issue.
Posted Mar 10, 2025 - 15:28 EDT
This incident affected: Web Application.